Download

Cloth simulation not working in UE5

Hello, I migrated my project to UE5 (from 4.26) and suddenly I found out that my PlayerCharacter’s animation doesn’t play cloth simulation. I checked that the cloth simulation stuff is there, and that the cloth simulation is actually correct, when I play the animation in the editor.

So I tried to place the character into the scene and just set the animation to, for example, running and I see that it also works. I was investigating what can be wrong and I kinda didn’t find an issue, I checked like 8 characters (because player can be one of those) and none of them is working - the cloth is still “static” as I move the player around.

As I was checking, the only thing so far that seemed that could cause the issue could be, that I spawn the player character at runtime (like I have InitPawn which feeds some player spawn data and based on that the actual player character gets spawned).

My player character is composed of several submeshes and uses “set master pose” approach to sync the animations between the submeshes composing whole character, as player character’s appearance is modular, but from my investigation it didn’t seem to cause the issue.

So to sum it up - I place actor with skeletal mesh component (or subcomponent) which have clothing physics in the scene and set it up to play looping run animation and everything is fine. I spawn the character for player using c++ “SpawnActor” approach and posses it with the PlayerController and move the Player Character around the map and all the skeletal mesh sub components doesn’t run the cloth simulations so the clothes keep “static” as I move the player.

I checked the log and there are those messages:
LogSkeletalMesh: Display: OnRegister[SK_Hair4HoodA]: [ClothingSimulationFactoryNv] is currently unable to provide a fully functional simulation for each of this SkeletalMesh’s clothing assets.
LogSkeletalMesh: Display: OnRegister[SK_Hair4HoodA]: The ClothingSimulationFactory property will now be automatically updated to use the most functional simulation that can be found.

I guess it’s related but I’m not quite understanding what is going on.

Thanks for any help or info related to this issue.

Have you found a solution to the cloth issue in UE5? I’ve also notice cloth options are there, but it just doesn’t work. I tried adding to a new skeleton mesh, and it’s not possible. Curious if you have a solution.