Download

cloth not working, please help

EDIT4.24 SOLVED CLOTH ISSUE8/18/2020

https://youtu.be/flfA56uaA-0 ← GO HERE TO SOLVE YOUR CLOTH ISSUE, i mad the video for everyone to help lol.

So…Before i go full blown hulk on unreal engine or my computer. i will put my anger aside from this rediculous issue for a moments time to ask, why. Why is this super simple and almost seemingly newbie tutorial of creating cloth not working at all. the texture stays put, but the mesh moves. I followed the documentation and multiple videos, yet no result as to why the cloth is not working. omg, ive been through every **** setting. please for the love of all creation, someone f*****answer this.

https://youtu.be/vfcinMG_f4w

ps the mesh moves becuase i went to character, clothing, simulate character clothing. if its turned off, all you see is well, nothing

4.24 SOLVED CLOTH ISSUE

this is just so freaking dumb. everyone else isnt having an issue. well except the three people ive had try it and they too have said its not working for them either. Same results. there has to be something missing, the link we followed to do the cloth is here. https://youtu.be/kjOq8OB_3AQ

after further review. it is a bug within the engine of 4.24. We tried it on 4.23 and it works just fine. so Epic, will you please fix this asap.

Solved: the original process doesn’t work. needed to click create, then brush the material, then click apply. not create, apply, brush.

This is driving me crazy… how did you get it work… honestly apex clothing work flow was better than what we’be been left with.

I get this far - there’s a clothing mesh, but its not attached to my actual mesh - what am I doing wrong ?

w_jones go here, i made a video that shows how to get the cloth system to work in ue4 4.24. https://youtu.be/flfA56uaA-0

You sir just solved my issue, thank you big time.

Hey is anyone else having a problem deleting their skeletal mesh? I’m trying to delete this cloth sim I had going but I keep getting this error message:

SkeletalMesh /MyFilePath/Flag.Flag is in use.


Running the editor with ‘-NoLoadStartupPackages’ may help if the object is loaded at startup.

External referencers of SkeletalMesh /MyFilePath/Flag.Flag:
ClothPainterSettings /Engine/Transient.ClothPainterSettings_0 (root) (1)
0) ObjectProperty /Script/ClothPainter.ClothPainterSettings:ClothingAssets.ClothingAssets

Internal referencers of SkeletalMesh /MyFilePath/Flag.Flag:
ClothingAssetNv /MyFilePath/Flag.Flag:Flag_Clothing_0 (1)
0) [native reference]]

@BlindExposure Thanks for the solve!

However, once I’ve applied the clothing data I can no longer edit it in any functional way. Does anyone else have this issue, or found a workaround?

I’m also getting some weirdness to the material… When I apply the clothing data it changes the material, it seems to make it more metallic???

This also worked for me, hope it gets fixed soon! Thanks!

This works!

Thank you!!

I have the same problem. I use 4.24 version. Once I’ve applied the clothing data I can no longer edit it. Can anyone help me?

Today I found a way to get around the edit issue. If you look carefully in the cloth tool, there is a “Copy Clothing from SkeletalMesh” dropdown. This is my current workflow:

  1. Create a duplicate of your mesh. (SomeClothMesh -> SomeClothMesh_Duplicate)
  2. Create cloth data in SomeClothMesh_Duplicate
  3. Do all your cloth editing in SomeClothMesh_Duplicate
  4. When you are ready to preview. Go to your original mesh SomeClothMesh.
  5. Delete existing cloth data.
  6. Use “Copy Clothing from SkeletalMesh” drop down in Clothing Data tab.
  7. Apply cloth to section

This seems to work every time. I get the impression that the copy clothing method somehow does a clean setup every time. I noticed that this even works with using a proxy mesh. That is, your duplicate could actually be a low resolution cloth and it will drive the main one. No need to use the convoluted right click workflow without documentation.

go here, i made a video on how to do it!
https://youtu.be/flfA56uaA-0