Download

Cloth going crazy in game, fine in animation

Hi everybody! Sorry if this is a dumb question, but I’m still extremely new to the software. I’m trying to create a character with a long coat made of cloth. Model built in Blender, cloth painted in Unreal (4.26).

In the mesh and animation viewers, everything seems to work ok. The coat flows around the body, bounces off the legs, looks good, etc.

But when I try playing the game, it whips around like crazy. I’ve tried painting extreme weights (1000), very low weights (10-20), removing all physics capsules, rescaling and re-importing, but nothing seems to really have an effect.

Any ideas?

Here’s how it looks in the animation window
111

Then here’s how it looks in the game screen
222

Most likely your physics asset…In the game screen its actually using it, and you probably have large capsules on the legs

I tried shrinking the physics capsules and then deleting them entirely, but still got the same behavior.

I strongly suggest you to create the physics asset from scratch rather than modifying the existing one, since physics in UE is not always reliable.

After that delete all the capsule except for the one on the legs, scale them accordingly and try again.

Also, I’ve noticed 2 separate physics assets one for cloth and one for sk. mesh. get out of sync. Change the one for the body to the one for cloth and see if that solves the issue.

Bad idea.

There’s 2 phat assets for a reason.
The one for cloth is used to build cloth data. If you change it you have to go though and act like you edit the paint to get it to update.

OP hasn’t responded yet, but generally speaking you all are handing off not that great advice.

First of, the very first question to ask is almost always:
“What are the cloth settings?” (Bonus, “where did you get them from?”)

The second one should have been:
“Please screen-shot and share the paint”.

The third is:
“Do you know what a phat asset is?”
And
“Are you using one for cloth”?

Unless those questions are answered any and all suggestions are basically just a wild guess. Not that they are bad guesses, mind you.
The phat asset is very likely to be at fault here.

Thanks for replying.

To answer your questions:

  1. What are the cloth settings? Cloth settings are default, the errors occurred before I attempted changing any settings.
  2. Please screen-shot and share the paint. Ok!
  3. Do you know what a phat asset is? Maybe, I’m still very new. I do know what a physics asset is, how to create, resize and move one, but not much beyond that.
  4. Are you using one for cloth? Due to the frustration, I’ve been pretty destructive. As I mentioned above, I’ve deleted all physics assets except the legs in hopes of narrowing down the problem. So currently, yes, the only physics I am using are for cloth.

Screen shots of cloth settings, physics assets and paint.



Paint is just wrong.
It needs to FADE from black to white. Also the distance from the origin should probably be a max of 30CM for your specific asset. I’m guessing it’s just painted with a 100 default.

Follow this at x2 speed: