Download

Climbing animation keeps looping

I’ve followed a long video about how to make character to grab and climb walls, the grabbing part had a good result, but the climbing part is where it works 90%. Whenever I press the jump button, the animation plays well and correct, but the montage won’t stop. I think it has something to do with the anim blueprint. I’ve set like this:
If “isClimbing” boolean is true, then it’ll go to the climb animation, then when the animation is finished, then it should go back to the idle/walk/run state. First photo is where climbing is true and second photo is where climbing is false. Did I do a little mistake on the second pic?

EDIT: This is the tutorial that I followed: https://www.youtube.com/watch?v=H2xqW7lKkyw&t=644s

yes, if this is the picture that are you asking about, then yes

Nope, still loops

*sigh I have everything the same as you have and the animation still loops. I even renamed myself the “CanGrab” variable to “CanGrab_0” because it didn’t got renamed by itself. Here is my entire blueprint:
[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_134830_1523538667344_290”}[/ATTACH]

I also forgot that I even use the head rotation blueprint where it makes the head rotate with the mouse. I tried without that state machine and just connected the new state machine to Slot TPS and still the same. There is no mistaken because the climbing animation will never play if I don’t add it to the anim graph like in the 2nd screenshot. What am I doing wrong?!

Yes it is

*sigh Still nothing…

For some reason, the notifier is now working because i moved the “ClimbingEnd” notify a bit back