Download

Client character won't run

Set max walk speed just isn’t working on the client.
On the client, the running animation will “update” to match the new velocity, even though it’ll still have the same walk speed.
If you look to the running character on client from another client character or the server, it’ll look like he never began running.
Here’s my setup :

30343bfd0fe1100a11ccd17c5a5d583a2eca6e37.png

I tested more and tried other setups.
The max walk speed is changing both on server and client, but for some reason the character max walk speed just remains the same.
Here’s what i’m doing now. I’m doing a very similar thing with jump, the variable value change both server and client but the character won’t play the animation for others.

Give me a few mins, I made a video for you to show you 3 different ways to do it

Here you go, I did it in the character blueprint, but it should apply in the player controller as well, as long as you get the references right.

Unreal Engine 4 - (Tutorial) Replicated Jog/Sprint
https://www.youtube.com/watch?v=DUSQxiGJEd8 (Done! Finally!)

If you like what you learn in this video, feel free to join my patreon page at the $10 tier to unlock access to all my tutorials, where we are doing all kinds of shooter replication things in blueprints!

https://www.patreon.com/iamjohngalt75

YouTube must be backed up, still processing the video give it a few!!!

Its done! Finally YouTube is dragging

Before you posted your video i were able to make it work for the jump, now the run work aswell, even though i have no f-ing idea why it wouldn’t work before.
The way to do it from your video? That’s how i tried to do it in my first attempt, but on the “wrong way”, the one from the post was a “ctrl c + ctrl v” from the answers hub, there it worked, for me it didn’t , because i was doing it “the wrong way”.
But the reason it wasn’t working i can’t figure out. Basically, if i do it on the MyCharacter BP it’ll work, if i do it on the MyController BP it won’t. No idea why.
I tried to make the character reference variale replicated aswell but it did nothing. If you guys can help me figure out why it won’t work on the Controller BP will be great.

Heres the screen shots :
1be505a931d1eea6a2e006f8c1d9de162ba0c8af.png

7124e5741d0c201f7cdc4d112548f59b6d343f59.png

EDIT :: I made it work…
Big facepalm… the problem was : i was setting the character reference in the “begin play” , but the begin play was not replicating to the server… was simple as that…

Ill do another video a little later and do it from a player controller instead…time for lunch now check back later. Id wager to say its because the player reference is wrong, but ill see what I can do.

I didn’t create a new reply so you probably didn’t see it. The problem was because i was using the character reference variable from the begin play, but the begin play wasn’t being replicated to the server. Can’t say i’d have it done it without your tutorial though.

Ok awesome, I figured that’s what it was, glad you are all sorted out now!