Client Character is shaking when walking


my client character is shaking weirdly when I walk right, left or back.
I know what setting is causing the error it is the Use Controller Rotation Yaw.
When I set it to true then the character is shaking.
Strangely the server character does behave like it should.

I don’t know what I did wrong thought I hope someone could help me.

Thanks Tobias


I have tested this in my networking test project, but I’m not seeing any shaking or jittering on my end.

In order to test this on my end, I’ll need a way to reproduce it. Please test it in a clean project to see if you can recreate the issue. If you can, please provide a detailed list of repro steps.

Have a great day

Hi and thanks for your answer,

I have already tried it with a clean project and there I have the same problems. I made a new third person C++ project. Then I opened the character Bp under ThirdPersonCPP/Blueprints. In the Bp I under the class settings I set Use Controller Rotation Yaw to true. After this I set the Number of Player to two and pressed play. In the client window the character shakes strange when I walk, right left or back

I wish you a great day too : )

Thank you for the information.

I was able to reproduce the issue in 4.14 and 4.15, but in 4.16 Preview 2 I’m not seeing that same jitter. Go ahead and give it a shot in 4.16 P2.

Let me know if you still experience the issue and I can take another look.

Have a great day

Thanks, but It still doesn’t work in 4.16 Preview 3
and I was to late to test it with Preview 2.

Unfortunately, I’m not seeing the jitter on my end at this time. I’ve tested this in preview 3 as well. Without a repro case, we are unable to take any further action on this at this time. It could be something relating to your connection, or the number of programs that you have running in the background. I noticed when I was running the editor through Visual Studio, I was experiencing some slowdown.

Have a great day


I wanted to switch between simple and aiming movement. I’ve create an aiming movement in animation blueprint, and when I hold down the right mouse button, I switch to aiming movement. When I do that I turn off the Orient Rotation to Movement in Character Movement Component, and turn on the Use Controller Rotation Yaw. In Character Movement properties, below Networking I switched Network Smoothing Mode to Disabled.

I hope it helps.


Thanks a lot that helped : )