Click test

The check for pressing the E key does not work. The character must collision, press the button, after which the action will occur. What am I doing wrong? It’s all inside the actor’s blueprint.

Did you enable input?

Also, did you uncheck ‘consume input’ on the E key node?

1 Like

All settings are enabled. I think the problem is that the click test is inside the object’s blueprint, not the character or level blueprint. But I don’t know how to move the Begin Overlap.

Did you enable generating of overlap events?

Try add a print string right after the event begin overlap…
If it is not fired… You missed that checkbox in the sphere colission settings (GenerateOverlapEvents).

You need it in the object.

The object only accepts input when the player is overlapping with the box.

1 Like

The screen shows the correct information, you need to enable all the settings, Google it may be you find a better solution from there.