Classnotfound while building for Android

Ok, I accept I am getting old. I can see it every day in the mirror. What is still puzzling to me, is how something like UE can pass as a finished product nowadays. I have been programming backends for trading and card transactions engines in C++ since '98. If I would release something that needs 4 hours or tinkering and installing/updating/uninstalling/configuring various 3rd party tools just to get to the compiling phase, I would be fired the next day.

When I get a tool, I don’t expect to have to fix it before I start using it !

Anyways. The world is full today of “quantity vs quality” products. When I saw the “BUILD COMMAND STARTED” line in the log I was about to forget the frustration and start to think about celebrating.

About two minutes later, my happiness was gone:

UEDeployAndroid.MakeApk: ====1/19/2021 2:46:29 PM====PERFORMING FINAL APK PACKAGE OPERATION=====-armv7===========================================
UEDeployAndroid.GetMinTargetSDKVersions: Fixing minSdkVersion; NDK level above 19 requires minSdkVersion of 21 (arch=armv7)
UEDeployAndroid.CreateRunGradle: Creating rungradle.bat to work around commandline length limit (using unused drive letter Z:)
UEDeployAndroid.RunCommandLineProgramWithExceptionAndFiltering: Making .apk with Gradle…
UEDeployAndroid.FilterStdOutErr: Downloading
UEDeployAndroid.FilterStdOutErr: …
UEDeployAndroid.FilterStdOutErr: Unzipping C:\Users\vlada.gradle\wrapper\dists\gradle-6.1.1-all\cfmwm155h49vnt3hynmlrsdst\ to C:\Users\vlada.gradle\wrapper\dists\gradle-6.1.1-all\cfmwm155h49vnt3hynmlrsdst
UEDeployAndroid.FilterStdOutErr: Welcome to Gradle 6.1.1!
UEDeployAndroid.FilterStdOutErr: Here are the highlights of this release:
UEDeployAndroid.FilterStdOutErr: - Reusable dependency cache
UEDeployAndroid.FilterStdOutErr: - Configurable compilation order between Groovy/Kotlin/Java/Scala
UEDeployAndroid.FilterStdOutErr: - New sample projects in Gradle’s documentation
UEDeployAndroid.FilterStdOutErr: For more details see Gradle 6.1.1 Release Notes
UEDeployAndroid.FilterStdOutErr: To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: The Gradle Daemon.
UEDeployAndroid.FilterStdOutErr: Daemon will be stopped at the end of the build stopping after processing
UEDeployAndroid.FilterStdOutErr: java.lang.NoClassDefFoundError: Could not initialize class org.codehaus.groovy.vmplugin.v7.Java7
UEDeployAndroid.FilterStdOutErr: at org.codehaus.groovy.vmplugin.VMPluginFactory.(
UEDeployAndroid.FilterStdOutErr: at org.codehaus.groovy.reflection.GroovyClassValueFactory.(
UEDeployAndroid.FilterStdOutErr: at org.codehaus.groovy.reflection.ClassInfo.(
UEDeployAndroid.FilterStdOutErr: at org.codehaus.groovy.reflection.ReflectionCache.getCachedClass(
UEDeployAndroid.FilterStdOutErr: at org.codehaus.groovy.reflection.ReflectionCache.(
UEDeployAndroid.FilterStdOutErr: at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.registerMethods(
UEDeployAndroid.FilterStdOutErr: at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.(
UEDeployAndroid.FilterStdOutErr: at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.(
UEDeployAndroid.FilterStdOutErr: at groovy.lang.GroovySystem.(
UEDeployAndroid.FilterStdOutErr: at org.codehaus.groovy.runtime.InvokerHelper.(
UEDeployAndroid.FilterStdOutErr: at groovy.lang.GroovyObjectSupport.getDefaultMetaClass(

Any ideas how this could be solved ? I have tried to send the question to support but ( not at all surprisingly ) “There was an error contacting the remote service”.