Clamp Texture Edge stretching-

Hi all, I am having this problem.


I want to tile a texture without repeat by changing the sampler source to clamp but the edges are stretching. Any way to fix this.


Wouldn’t changing it to wrap be the way to accomplish this?

I meant scale the texture without tiling or repeating.

A bit late but to anyone who has the same question, I had a 1024x1024 texture which was stretching with clamp on and I was able to solve it but setting an 8x8 black pixel border around my texture so the rest of it fills black. Try deleting or adding a certain amount of pixels around the texture to get rid of it. Although, I’m not sure if it will work with a border of pixels with alpha 0 but you can try and see.