Clamp (float) won't work well when I set min & max value with variables

Hi.
I’ve stuck up when I tried to clamp float with variables.

When input the min & max values directly, my “Clamp (float)” works fine as I wished.
But when inpu the min & max values with variable, those set to the same values as direct input, it won’t work well.
As specifically, it returns “0” when the input float enters minus.

Can anyone explain why this happens?

–This one works–

–This one DOSENT work–

Have you set a break-point on the Clamp and checked those 2 variables are correct (and not reversed)?

1 Like

Thanks for the help.
I set break point on “SetWorldRotation” (though it’s outside of the picture) and watched the values.
And my min variable returns “0” although its default value is “-45.0”.
How can I fix this?

image

1 Like

For a moment I made clamp by myself and it seems working.

I just tried it here and I had no problems. Are you sure you haven’t set the Min and Max amount your variables can be?

1 Like

It seems a kind of dupulication issue.
I deleted the Min variable and compiled once, and made a variable again then re-compiled fixed the issue.
Thank you for all. I close this question.

2 Likes