Download

Cinema 4D models aren't importing properly

I have one model in particular that has missing faces when i import the static mesh from Cinema 4D. I am exporting as fbx files. All of my static meshes have been working fine.

Basically i can see the inside of my object.

Hope someone can help.

Thanks

Whenever you have issues like that, make sure to attatch some screenshots of the Object.
Depending on the kind of issue you have either shots from within the 3D app, UE4 or preferably both.

With as few information as given in your text, i think it might be an issue with inverted face normals.

backface-culling_01.jpg

As you can see in this Image, the color of the face tells you about it’s orientation.
When selected in polygon editing mode the normals of the Orange faces point outwards and this is considdered the front face,
while blue faces indicate a reversed normal so you see the backside of that face from the angle you’re looking at it.

In realtime engines like UE4 the so called backface culling is active by default to prevent unseen faces from beeing rendered.
Some 3D apps have backface culling on by default too (3dsMax, Maya?) in other 3D packages like Cinema 4D it’s off by default, which makes perfectly sense for editing.

You can toggle backface culling as well as many other rendering options on and off in the viewport options.
(you can also display facenormals and in R18 even vertexnormals in the viewport)

backface-culling_02.jpg

Usually you want to have all face Normals pointing outwards, but there might be situations where you need them to face into the other direction or even disable backface culling.

The leafs of a tree model are a good example for this.
Usually they are using textured planes with alphachannel on them.

Now there are two options to make them render both sides.

  1. you could duplicate the whole leaf geometry and invert the face normals on the copy.
  2. or you can disable the backface culling in the leaf material in UE4 by checking the “two sided material” option in Material Editor

What way you choose depends on your preference and sometimes even on the model setup itself.

Just for example: if the trees trunk and leaf texture are one material (which is also not a good idea for other reasons), disabling the backface culling will always render all polygons of the tree.
Might not be a big issue for one tree, but it will be one for a whole forrest.

I also use C4D and it’s a little frustrating that the workflow to game engines is weak. This tip about the Two Sided Material is amazing! I had no idea and have struggled with this problem making levels for UT. Thanks!!!

:smiley:

Just to make it clear:
the two sided material is only usefull in certain situations like the leaf example and not meant to be used for issues caused by partially flipped face normals on models.

E.g. if you use it on a solid cube with 6 sides (12 polygons), by default only 6 of the 12 polygons are rendered, because the other polygonms are culled.
Applying a Two sided Material will enable the rendering of all 12 polygons no matter if you can see them or not.
Now imagine whole scenes with 100.000 polygons where roughly 50-60.000 are rendered or all 100.000 polygons are rendered.

You can easily invert face normals in C4D and every other 3D modelling software out there, so there’s no excuse to use two sided materials for this purpose.