Chunks are not working on WindowsNoEditor

Hello, I tried to separate my asset files into different chunks, but as my Asset Audit shows, they are working only on Editor: if I switch to WIndowsNoEditor on Asset Audit, a lot of assets go to chunk 0.
Anyone can explain me why? Thanks in advance!

Editor:

WindowsNoEditor:

2 Likes

Hello. Were you able to solve this problem? My blueprints don’t show up with WindowsNoEditor either.

Unfortunately no, I was not. I simply disabled the chunk system for now.

Sorry to hear that, but thanks for the response.

Hi. I created a ThirdPersonExample project from the template and tried to compare the settings with my project. After trying different settings, I discovered what my problem was.

The difference was that I had a starter map listed.
Project Settings → Packaging → List of maps to include in a packaged build

I cleared this list. After that the build process took much longer than before. But, now in Asset Audit if you select the platform WindowsNoEditor displays created PrimatyAssetLabel and their Actors.

And the right-sized chunks are created in the Content\Paks directory.

I hope this helps you as well.

1 Like

Thanks for the answer, as soon as I work back on the project I’ll try it, hoping it works!