Chunk downloader corrupt Manifest

I followed this part of the documentation Patching and DLC | Unreal Engine Documentation

I am stuck in the middle of Implementing the ChunkDownloader Ingame part 4. When I start the game the manifest is downloaded but the editor gives me these errors:

LogChunkDownloader: Error: Manifest parse error at …/PersistentDownloadDir/PakCache/CachedBuildManifest.txt:3
LogChunkDownloader: Error: Manifest parse error at …/PersistentDownloadDir/PakCache/CachedBuildManifest.txt:4
LogChunkDownloader: Error: Manifest parse error at …/PersistentDownloadDir/PakCache/CachedBuildManifest.txt:5
LogChunkDownloader: Error: Corrupt manifest at …/PersistentDownloadDir/PakCache/CachedBuildManifest.txt (expected 3 entries, got 0)

this is the manifests content
CachedBuildManifest.txt (341 Bytes)

I tried already a version where I had ver instead of Version001 but with no success.

1 Like

Having the exact same issue, did you find a solution to this?

Experience the same issue. There is a big disconnect in the documentation on Chunk Downloader and the Video.

Followed the Implementing ChunkDownloader tutorial via their site and the video on Youtube. Getting the LogChunkDownloader: Error: HTTP 404 while downloading manifest from - error. Anyone fixed it yet?

1 Like

Quick tips for anyone who may encounter this error:

LogChunkDownloader: Error: Manifest parse error at …/PersistentDownloadDir/PakCache/CachedBuildManifest.txt:3

I wasted a day of my life trying to figure out what was wrong…
It is VERY important to keep this format for each pak line in your BuildManifest files:


Ex: pakchunk2001-WindowsNoEditor.pak[TAB]649382806[TAB]ver001[TAB]2001[TAB]/VariantA/pakchunk2001-WindowsNoEditor.pak

[TAB] = The real TAB character (ASCII #9). Not space or any other characters!

I got this error when using VSCode to edit my BuildManifest files. With VSCode, when you press the TAB button on your keyboard, it actually adds 4 space characters instead of a real TAB character. This means that your pak list in the BuildManifest will not follow the correct structure and it will crash. You can see where it crashes in the code here: ChunkDownloader.ccp line 332.

1 Like

I got it working by using Preparing Assets for Chunking | Unreal Engine 4.27 Documentation to generate the pak files and Pak Loader Plugin in Code Plugins - UE Marketplace to load them. Well worth the money to avoid the pain of figuring that out myself.

This is how I load a map and a blueprint.

In 5.1 I additionally needed to check the map used in the extra chunk for cooking under Cooked Maps in the Project Launcher for it to be in the pak (worked in 4.27 without checking).

1 Like

this is because u name manifest.txt so make sure create a text file and name it BuildManifest-Windows i did same mistake after looking at the local host on chrome there it showed .txt.txt hope it helps

not gonna wanna pay when it super ez to implement i feel like

if anyone is having a parse error i believe it has to be formatted with tabs only in vscode for some reason the tabs are actually spaces, i think they use a regular expression in the chunkdownloader code in order to parse the manifest based off tabs.
I had to use sed to format it with tabs instead of spaces. here was the sed command i used to fix the manifest file :
sudo sed -i ‘s/ */\t/g’ BuildManifest-Windows.txt

@Unavi was it working with Mobile too? also is it just plug & play to manage the chunking system