Download

Choosing what Input controls?

Hey,
I am new to Unreal but have used Unity extensively. I am not sure how the input system works:

cb74d0f2f2001663514c356989551363b6264c10.jpeg

  1. If I run the above, even though Default Pawn Class is Dude1 (the green one), WASD still moves Dude2 (the blue one). What is causing this? How do I choose which Input affects.

  2. How do I make a Character spawn at PlayerStart? (i.e. blue and green would be stood there and I would be able to choose either blue or green to spawn at PlayerStart when Play is pressed)

You will have to make the player choose between blue or green first before you spawn the characters. Then the one he chooses should spawn and the other won’t. Set up a basic UI in UMG and make a switch.

If you click on a pawn in your level, then in the details panel under “Pawn” there’s a setting called “Auto Possess Player”. In the 2d sidescroller template, the pawn is set to auto possess player 0, that’s why it overrides any player start actors or other pawns you put in. Also, in your blueprints, if you click on an input event node you’ll see a few check boxes in the details panel. The first one is “Consume Input”. So if you want multiple blueprints to use the same input event at the same time you’ll have to make sure that is un-checked.

If you want to dynamically switch between pawns, you should do that in a player controller blueprint. It’s very easy, you just use the “Possess” node.

Thankyou so much, that was confusing the **** out of me. Nothing explains about that autopossess thing and it’s hidden right down at the bottom. Cant believe something so simple was something so difficult.

Hey Ross,
Don’t mean to be a nuisance, but I have another issue that nobody seems able to help me with have been struggling with for a few days: https://forums.unrealengine.com/showthread.php?95755-Capsule-Collider-Floating-Problem&p=445786#post445786

Haha, no problem. Unfortunately I have no idea how to fix that, sorry. I’ve never used the character classes. I did find this thread: https://forums.unrealengine.com/showthread.php?11931-Tiny-capsule-component-offset so if your character is really really tiny that might be it. And I assume you tried all manner of “turning it off and turning it on again”? (deleting and replacing the character in the level, etc.)

You could also try asking on the answerhub.

Those “Movement Capabilities” settings, like “Nav Agent Radius” etc., are for the navmesh, they shouldn’t have anything to do with collision.