Child component needs scene component to work properly

Hi!

I created a class blueprint called PhysicsBox, which contatined a static mesh with enabled physics. Then I created an empty class blueprint which was called ManyBoxes (from QuickShot tutorial No. 6) which created PhysicsBoxes as child components.

The blueprint that I used in ManyBoxes:

Radius and HowMany are editable variables.

But when I tried to use it, I found that all child components are moving away. I tried to use wallSconce blueprint with enabled physics, and all worked perfectly.

I checked the differences between this two blueprints, and found that PhysicsBox doesn’t contain Scene component, but the wall sconce contatins. When I added it to PhysicsBox, all worked right.

I created a thread about this on forum, where this problem is described with more details and photos (answerhub has a limit of photos): Child component moved away - Blueprint - Unreal Engine Forums

With best regards,

UCoder123

Hi Ucoder,

Thank you for your report. I was able to reproduce the issue and am now looking into so potential fixes that are coming up. I have entered a report into our bug database just to be safe though. For now, I would suggest just using the scenecomponent as the root if that will not cause any problems. Let me know if anything else is behaving unexpectedly.

Thank you,

Alexander