Child Blueprints not retaining all values after editor closes

I’ve been having an issue with Child blueprints not saving and changing odd parms on me, and was wondering if this was an issue with the Unreal Editor, or if others had come across this?

I am working on an FPS for fun / myself for a while now and have been using the Generic Shooter blueprint from the marketplace. Recently I’ve begun work of putting all the pieces I made over the last couple years into a functional game. So my goal is to make as much of the game in child blueprints as I can so I do-not miss out on generic shooter code updates or I only have minimal fixes to my own code after there are updates.

I started with making a Child Player Character blueprint and everything is fine as long as I do-not close the Unreal Editor. As soon as I do some parms revert back to defaults or values they were never set to. Regardles of how many times I save or recompile the child BP.

For example in my child blueprint I have the mesh transform set to -94 Z location and -90 z rotation, and the animation blueprint set my my animation blueprint. The only thing different in the child from the parent in these parms is the animation blueprint. But after I close the blueprint it sets the child zLocation adn rotation both to 0.

Desired Settings:


After reopening the editor Location, Rotation, and Anim Blueprint settings are lost. I kind of understand / can see how the the Anim Blueprint could be getting lost, but Location and Rotation are not changed at all from the Parent.

Lost Settings:


What then gets stranger is it does this to the 1P mesh as well, except on the 1P mesh it retains the Location and Animation Blueprint fine, but resets the rotation to 0.

I’ve noticed more issues like this with some of my other child blueprints as well lately, and its getting difficult to keep track of and have to reset values every time I close and open the editor. Its odd because I cannot find a pattern as to why these values reset and not others. Its the same with some of my other blueprints as well. I’ve also tried resetting the parent blueprint values to see if it would cascade down and no such luck. The values still reset.

The other concern is no matter what all these values seem to get lost when I compile my project as a stand alone game.

Anyhow if anyone has experienced something similar or knows of a work around please let me know. In the mean time if I come across a resolution I will post here in case others experience the same.


I have same problem in 4.12.5

FYI to resolve this I just did a workaround. The workaround was to change the value such a tiny bit it forced it to save the change. For example I changed the rotation from -90 to -90.0001 and it seemed to stick. Not the best of workarounds but works for now at least.

I have this same problem in 4.13

Still happening after crash in 4.14

I setup a lot of variables inside the master blueprint, all gone. Seems i have to set all these values on event begin play too…

This issue still occurs in 4.14.1
I FINALLY found a weird workaround that worked for me, and that was reparenting my Object-derived data blueprints to ActorComponent (really just the first class I tried) and now my values in the child classes seem to save again. I doubt this will work forever, but I’m hoping I can bounce around reparenting to a different ActorComponent each time this happens, but if I need to do it again I will report back

My “workaround” so far has been switching my entire project to c++ : /
It’s not optimal, and for anyone late into their project not viable, but it’s guaranteed to solve the problem.

Yeah, my work around was to Chang the values just a tiny amount a d That seemed to fix my issue. It was not a perfect solution but worked. For example I changed the rotation from -90 to -90.0001

Unfortunately the most recent value that wouldn’t save was a boolean, so I couldn’t barely change it hah. And no matter what I did, it would not save! Very frustrating and makes me nervous I will randomly lose even more data!

Can confirm as well. Child blueprints are inexplicably losing their values in 4.14.1, sometimes it’s all of the children, sometimes it’s some of them.

I haven’t been able to find a reason for it, my editor isn’t crashing or anything strange, just sometimes I’ll start the project and inexplicably an entire class will just lose its values.