Download

Child blueprints: Can't modify inherited components?

I’m having an issue where I cannot edit an inherited component from within the child blueprint, and if I update the component in the parent after construction the component doesn’t update in the child.

What I’m trying to do is inherit a SpringArm from a parent blueprint, into a child, and then set that SpringArms length using values from the child.

one time bump

Hello,
I just tried with a third person character blueprint. I created a child and in event graph : right click : cameraboom : down of list, under character : get cameraboom. from it : set target arm length. And i did a flip flop to try to change it. In hope it will solve your issue.

When I check the SpringArms length it’s reflecting what I set it to, but the SpringArm doesn’t actually extend.

Ended up rigging a different method to accomplish what I needed without the SpringArm, but there is a chance I’ll need the SpringArm down the road.

Could this have anything to do with the SpringArm being the root component?

Also, you didn’t mention if your test was successful?

Yes, it worked fine but i used a character blueprint as parent (capsule component as root). Maybe would you try to set a sphere as root.