Child actor Owner see/no see

This issue makes me want to die. Caused days of pain

My fps multiplayer game has 2 weapon models of the same gun, being one for first person (for client) and one for third person (for other players). The first person gun should be owner only and third person gun would be owner no see. They are both under 2 parent meshes that has the right owner see/no see settings. However the settings don’t seem to carry over to child actors. How can I, or is it possible to set owner see/no see values for them? So far I have found no way to setting owner see visibility for child actors components.

Why not add the model to the owning actor?

there is a visibility option that you can check you can also control it thought blueprints by set visibility etc

What I did was set the owner to self on the child actor on an event in the character, ie Begin overlap in my case, and then set owner no see on the child acters components that have owner no see as an option.