Child Actor Components lose Child Actor Template

Freak my life… And I was going on about how great Child Actors have been for my project. That Epic has worked some magic into making them great again…

And then, who knows when or why… but just a second ago, I wanted to do a change to my current child actors in my blueprint… and I couldn’t see the Child Actor Template, AKA, where you can setup the default properties for those actors…

So, I put a new one in, and I can see CAT just fine. It’s just super annoying. Who knows what could have caused this within the last month since the last time I changed those properties…

So, since I can’t repro this, I guess it’s more of a heads up that Child Actors are still glitchy, and if you lose the ability to change the properties, just replace it with a new one.

Hmm, just out of chance, I noticed an easier way. By just getting the same actor, it will refresh it.

But THIS does NOT resolve anything in the end. Only in editor. I get packaging errors now!

And nope… regressed after one successful package. Sigh. Not sure what is causing this sadly.

Ive been having the same problem. I opened a bug report for it, see how that goes. I managed to get it to load up without the error by removing all references to the child actor, variables and casts (which obviously completely defeat the purpose of having a child actor). Still no idea why this happens exactly.

Also refreshing the actor in the drop down doesnt resolve because it revert all of the variables to defaults.