Download

Checkbox Bug

Hi everyone, I can’t manage to change the appearance of the checked checkbox.
I loaded an image but I still get the default check instead of it. As you can see in the attached picture, the “unchecked hovered” and “checked hovered” have the same setup but I get different results.

In UE 4.26 this kind of setup worked fine.
Any help? I don’t want to switch visibility on 2 different buttons, it’s a messy solution.

Thanks!

Scroll down a bit, and you’ll see “Foreground Color”. Set that to (1, 1, 1, 1). That should fix it.

Hi,

you need to set ImageType for checked brushes to ESlateBrushImageType::NoImage. By default it’s set to Vector and because of that your image is ignored and default svg is used (Engine\Content\Slate\Starship\CoreWidgets\CheckBox\check.scg).

I believe you can’t do this from blueprints.

1 Like

Thanks for your replies.
Today I opened the project again, I made a new CheckBox and the appearence for checked state was fine without changing anything :face_with_monocle:

That’s weird !

I would like to say that I too am experiencing issues with checkboxes in UE5. If you use the box as default everything works just fine. This is a project that was migrated from UE4 to UE5. Everything worked just fine.

One thing I notice is there is now a background separate from the checked/unchecked state images. If you modify these states, it screws up the entire checkbox, even if you set the Style back to default. It will never look correct again.

There has to be a bug here somewhere. I would like someone else to confirm this for me as well before I open a bug report.