Download

characters (static meshes) slow down the game ?

Hi !

In a project I made few weeks ago I was creating a museum with like 25 or 35 animated static meshes of characters.
The characters was lowpoly but even tho, the game had a very low framerate when I was looking at them and when I don’t look them it’s fine.

What could be the solution to this ? Instancing the static meshes ? How can I do that ?
Please help people, thanks in advance :slight_smile:

Are they static meshes or skeletal meshes? An animated skeletal mesh will have more performance impact

Hmm I think it could be that, as I just wanted the animation I did import the animation object and it appears as a static mesh :confused: I used MakeHuman to create the character (with a mod to make a lowpoly mesh) then mixamo for animations and when imported in UE4 it gave me : mesh, skeleton and animations object. I put in my scene the animations objects.

Is that the cause of the low framerate ?

No response, up

You could start with a description of your kit. What CPU? What GPU? How much memory?

What platform? Is the project desktop,Vr,Mobile?

By drop in frame rate by how much?

Are you using complex shaders (Press alt 8 and if you see a lot of red that’s bad. White extremely bad)

It should be noted that FPS is no longer a reliable means to determine performance loss as say compared to refresh rates and GPU profiling.

A drop in FPS “could” indicate a CPU bottle neck where GPU profiling will tell you if you GPU is the bottle neck

Best practice wise as to figuring it out start here

https://www.youtube.com/watch?v=-csRxRj_zcw&t=208s

Do a proper profile as demonstrated you will be able to pinpoint the problem and not just say, think, your problem is related to performance drops when you look at something then improves when you look away. Doing so while working in the PIE is common and such testing for problems should always be preformed configured as to how the final result will be used.

I have an i5 last gen, nvidia gtx 960 mx, 6GB ram and I have a desktop third person project.
Actually I cannot access to my project because I moved it on my external harddrive but I would jst like to know a way to get an animation object like this less impactful on the performance.
Any solution please ?

Well on the hardware side your on the low end of the requirement spec to run UE4 in dev mode. You should have at least 8 gigs minimum. Spec wise the GPU at 2 gigs is rather low depending on the complexity of the scene.

To put it into perspective your showing up to a drag race with you moms Honda Civic :wink:

When using the PIE you are sharing resources necessary to run the the editing fractures so once again performance hits is not uncommon and you should be testing as fit to finish to remove he editor as a possible factor.

On your box you could try switching to Forward Rendering which has proven to increase performance by 25-30%

Check your engine scalabiity settings. If set to Epic that could be your problem.

Overall though performance tweaking is an art form so showing up and saying “I see this whats the solution” the only answer I can provided is “don’t do that” :smiley:

Oh okay thanks and How do I enable forward rendering ?