Characters are not moving accross projects!

Ok, here’s what happens.

I’m doing a game, and movement is not working (forward and sideways, the character is moving unbeliveable slow). I break my brain tryign to figure out why, so I say to myself: let’s create a new example project and copy-paste what’s on the character.

I create this new template ThirdPerson project AND THE CHARACTER JUST DOESN’T MOVE, JUST LIKE IN MY GAME!!!

I’m really clueless about this stuff.


Here’s the movement blueprint

And my components


Equipment and Inventory are C++ defined components. I tried movement with two more generic projects (FirstPirson and ThirdPerson) And the same thing is happening.

In This gif: Animated GIF - Find & Share on GIPHY you can check how the movement looks.

Can you show the character blueprint? ( also the components list ).

Hello ClokckworkOcean! Thank you fror you r reply.

I updated the original post with the info you asked. Also, I tried creating two new template projects (ThirsPerosn and FirstPerson) And the same thing is happening! It’s as if something would be ■■■■■■ up in the engine. Do you thin I should reinstall the engine?

Hello ClockworkOcean! Thanks for answring my question.
I added the information you requested to the original post.
Also, I tried this behaviour with two more new template projects (ThirdPerson and FirstPerson templates), and they don’t work either. Do you think I should re-install the UnrealEngine?

Well, I tried a bunch of things to see if that fixed the issue, because originally I had the default movement for third persone (the one you sent on the blueprint), so I tried using the camera as movement point, the capsule, the mesh. But it didn’t work. Also, the new third person project i created ALSO doens’t work. weird, huh?

It moves super slow, like there was something blocking it or something. Just like on the other project I have

I just tried your capsule movement with the default third person. It does move, but not in the correct direction. Why not just use the default code for this?

I’m assuming if you make a new third person project, the character moves correctly ( without any mods )?

So you make a new third person project, and what happens? The character wont move, or moves slowly?

And you’re pressing W to move forward? ( just covering all bases here :wink: )

You can check how movement looks like in this GIF. And yes, I’m presisng w.

Right, but that’s your character, isn’t it :slight_smile:

Does this also happen with the default character?

Yeha, happening with the First person and Third Person project template O.o I think I’ll reinstall the engine and tell you how did it go

So, news: I reinstalled the engine and it changed nothing. But i have a theory now: I’m using my computer over the network using TeamViewer, maybe it’s just the input is ■■■■■■ up because of that. I 'll go back home in a week, so I 'll find out then

I thought you were going to do that. Verify is easier:


Your keyboard works right? Other games, notepad etc…

Ah, could be that…

Open a notepad document, and press and hold W, does it work quickly?..

Hey there! just came back home frmo my trip.
I wanted to confirm that it was in fact remote accessing what was causing this behaviour, and here everything is good!. Thank you