CharacterMesh has to have 'Simulate Physics' enabled if you'd like to AddImpulseAtLocation

I’m using ALS V4 for a shooter and have the character go ragdoll once health is 0.

Once the health reaches zero, the mesh is set to PhysicBody, then collision is enabled, then simulate physics is enabled. (default ALS ragdoll function)

Once these preparations are done, I wait for 100ms, then I apply an impulse to the mesh, to increase the death impact. This returns “ALS_AnimMan_CharacterBP_2.CharacterMesh0 AnimMan has to have ‘Simulate Physics’ enabled if you’d like to AddImpulseAtLocation.”

I also added an impulse when shooting the dead body, and I get the same error.

This class is a child class from the character class, so the mesh is the inherited character mesh.

Probably because you’re simulating physics only for the pelvis bone and the bones below it.
EDIT: you’re not actually enabling Physics Simulation in the screens provided.

Can you attach a picture of your component list?

I checked all 4 combination of using the functions shown below, and they all got me to the same result.

  • The mesh go ragdoll and fall
  • I get the addImpulse warning
  • Every time I shoot, a new warning is added

I also tried setting “New Simulate” to false without success.

Am I forgetting something?

Sure! Here it is:


Removing the held object mesh and skeletal mesh didn’t change the problem.


As far as I remember, my problem came from having the wrong collision or physic preset. However, I’m not 100% sure, as it dates a few month.

After uncheck the EnablePhysicsInteraction in CharacterMovement ,the warning gone.

1 Like

You need to specify the BoneName in AddImpulse
For example, “pelvis”