Character won't move

Hey all! This is my first post, so I hope I’ve got things in the right place. I’m also a new user, so assume all that goes with that.

I started working with the side scroller example project and built off it. I’ve now got a character that won’t move. They receive input and turn, but won’t move on the Y axis. The character can jump, and will move along the Y axis in the air if I add a force. Loading the example character into the level works as expected.

This happened randomly after deleting and re-adding the add movement input

Here are the things I’ve checked so far.


controller inputs fire in the graph (below). The character will turn and in place on the ground and will move along the Y axis in the air, so inputs are making it from the player to the pawn and being processed.


I don’t believe I’ve modified the details of the actor much, but here are what I think are the pertinent ones.


Again, here are what I think are the pertinent world details. The game mode is set properly (the character does turn and move in the air)


I’ve run a diff on my character and the example, and can’t find anything significant other than a ‘player acceleration’ float in the example character. It has no references. Adding it to my character doesn’t fix the issue.


  • using the example character, works as expected
  • wiring movement input directly to add movement input, no effect
  • changing animation blueprint classes, no effect
  • changing input names (maybe xmovement is reserved), no effect

Any help is much appreciated as I continue to learn :slight_smile:

I added a print statement to make sure values are being set, and it appears that they are.

More things I’ve checked:

  • auto-activate of movement component, unchecking results in no turning, as expected
  • parent is character (so implements addMovementInput), also tried re-parenting, no effect

just a thought… only because I think I’ve forgotten myself and it had the same symptoms… have your implemented a movement mode on you Player Character?

I haven’t set one explicitly, but the blueprint in question is a child of Character, so it should implement it already.

Adding in movement mode setters in various places yields no change.

Additionally, The default land movement on the character movement component is set to ‘walking’, for what that’s worth.

yes, it sounds like this isn’t the issue

your setup looks OK, how is the input on INPUTAXISXMOVEMENT looking?

BTW. if the default land and water modes are set to “none” in the character component, I seem to remember it won’t move because it will be in “none” movement mode

specifically, are you getting a value > 0 for Axis value?

doh… sorry… I see you checked already.

By any chance, you didn’t accidentally tick Planar Movement settings on the Char Component?

I did, but the setup is the same as (copied from) the sidescroller template project. I also tried unchecking it, no effect.


actually, I think the above settings might be the issue… I’d look at them more closely

What would you suggest? I’ve disabled those constraints entirely to no avail.

These are the default settings… I’d suggest using exactly these just to be sure…


Tried that too, no luck.

Figured it out, and it was something dumb like I suspected. I made an initialize player function to set a bunch of variables, including the Max Walk Speed. My value for “base movement speed” hover around 1 (.8 for a slow character, 1.2 for a fast character, etc.), and I set max walk speed to a multiple of 500 of the base movement.

My issue

I had simply set max walk speed to 1 in my test instance. This explains why the diff between the sidescrollercharacter example and mine wasn’t informative, why no constraints made sense, why the logic appeared to flow properly, and why debugging the velocity values seemed to be proper. My character was moving, just very slowly.