Character Skeletal Mesh Loses reference on editing widget or HUD.

This is a very odd bug.

So there is a HUD BP, a widget BP, and a character BP.

The HUD BP gets information about the character and stores it as strings. The widget gets those string values through Text component bindings to display the information on the screen.

If I change or add any bindings in the widget, or reference the character, the character bp will not have a skeletal mesh assigned when the project is closed and opened. This means when the project is packaged it will not have it either. The clients will show the mesh in T Pose with no animations (I’m assuming they are removed when there is no skeletal mesh assigned) but the server will not render and mesh so no animations or sockets will work.

The same thing will happen if I edit the HUD at all. Sometimes I cannot even save the HUD and no reason is given.

I can open the game in the editor, reassign the mesh and the animations and the clients will look fine and sometimes even the server renders the skeletal mesh but every time the project is closed the mesh in the character is assigned to nothing.

Sometimes I can edit both the hud and widget and when reopening the editor I can assign the skeletal mesh and animations to the character and it will look like it is working (until it is closed and opened again). In this case though the bindings and references in the HUD will say they reference none when getting the information from the character some percentage of times.

Even if the mesh and animations are assigned on construction the server will still not see them so any actions done with authority will not work.

We have 4 programmers on our team and all experience the same thing. We are using the latest version of 4.11 from github.

Hello Burnrate,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints that may be involved?

Hi Rudy,

I haven’t been able to reproduce it yet.

Is there anything specific in the BPs you think I should take a screenshot off?

The working reference for player health is done by the HUD querying the player and setting a string with the text value of the players health. The text box in the widget is then bound to the string in the HUD through the sub object options in the bind dropdown menu.

If I remove that binding. edit the HUD in any way, or add functionality to the widget the error will occur.

Is there any way you could narrow down what you would like a screenshot of? There is a bunch going on in each BP and the widget.

random shot…have you tried on a totally different pc and migrating the content to a clean project?

Hello Burnrate,

Without more information I will not be able to tell you what screen shots I need exactly. I would suggest narrowing down the process that is giving you an issue to the absolute minimum setup that still reproduces this issue for you. From there you should be able to determine if it can be recreated in a clean project. Once you have it narrowed down you could then send the screen shots of what is left.

Hi , It happens on all the computers of all the people working on the project. I can’t really migrate the content without rebuilding the project and that is what I am trying to avoid.

Hi Rudy,

So with 5 programmers and the edits made by the artists, audio, and design folks over ten months the options of:

  • dismantling, closing and opening the project, testing for the bug at each change or,
  • rebuilding the project from scratch and testing each step,

are both options with the same amount of work that would occur if we just scrapped the project and started over. They aren’t really options.

We will update to 4.12 when the plugins we are using update. That may fix it and I will report back.

It’s a shame that the blueprints are so obfuscated. They should be a text xml recording position and connections and then that should be used to build the binary files. That would even allow blueprints to be used properly in version control.

Hello Burnrate,

If you are going update to 4.12 and then get back to me, I will be marking this post as resolved for now. Please feel free to reopen this issue with any additional information you may have. If updating to 4.12 does not resolve this issue I will be more than happy to assist you further.

Make it a great day

This post is not resolved. I posted a comment stating I was working on it. It is ridiculous to mark it as resolved. What is the ridiculous incentive to always mark questions as resolved when they aren’t.

This is why unreal answers are such a worthless garbage heap. Almost every answer marked as resolved is either because some staff says “Oh this is for an old engine” or “I haven’t heard anything in few days”.

All you have done is lower the quality of unreal answers and made another worthless answer people will be disappointed to find.

Hello Burnrate,

Information for your last question:

The post is marked as resolved for tracking purposes. This allows the user to be informed that the issue is awaiting some sort of response and it allows the staff member to be alerted when question has been reopened. This also allows other users with similar issues a chance to reopen the issue later and provide additional information. As stated, the issue is immediately reopened when a reply is made. I hope this helps provide more insight into the process.

Relating to the thread:

I noticed in your last post that you mentioned that you were using plugins in your project. Are you using any third party plugins that might be involved with this issue? If that is the case you will need to talk to the provider of the plugin for additional support, as we do not provide support for any unofficial plugins.

As mentioned above you were working on updating your project to 4.12. Did this resolve your issue or are you still in the process of updating? As a note please be insure to try removing your saved and intermediate folders before updating (you may want to make back ups just in case) .

Additional information:

While the information that has been provided thus far is helpful in narrowing down the general areas in which you may need assistance, we will need more specific information in order to resolved this issue. Resolve in this context meaning, to file a report, make corrections, and/or find an available workaround.

We are using VaRest and FMOD.

If you define Resolve in the context you listed above it loses all meaning. That is just some business major double talk. Instead of saying “The problem is being worked on.” they want to say “The issue has been resolved.”

The second sentence is a lie even if it is redefined inside some corporate structure, and it causes unreal answers to be almost completely polluted with useless ‘resolutions’.

Hello Burnrate,

Is it possible to reproduce this issue without the plugins mentioned in your last comment? If not, and if they are involved in parts of your project that you are having issues with, I would suggest contacting the creators of the plugins to check for possible known issues and/or solutions. Could you try contact them, and post back with information/ solutions you have?

The bug does happen without the plugins.

Right now any functional changes made to our HUD, Game Mode, or our main Widget which reference the players Character it will cause the Character BP to lose its reference to its skeletal mesh when you close and reopen the editor (or package and run, on both the server and client).

We are currently working on replacing those BPs with C++ all at once to see if we can eradicate the problem. Of course the character BP may be the problem.

Hello Burnrate,

Would you like to provide a copy of the project that you are working on so that I could take a closer look at not only the issue that you are having but the setup that is being used as well? If you would like to provide it privately you can do so by zipping it down and providing a google drive or drop box link to me in a private message on the forums.

Hello Burnrate,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

So we were never able to fix this problem or find the cause. We re-parented everything we could to C++ and made new C++ classes for everything else. We have most of the things back up and running. This left some of our BP devs in the cold for a while but we are all learning and finding a good balance of BP use.

Again I have to say that Unreal Answers really needs a different classification for questions; such as inactive or closed. Marking everything as resolved whether or not it is resolved makes Unreal Answers a huge field of disappointment. Most questions I find marked as resolved are not and have just been left inactive.

For example this questions could have been marked as Inactive for a while and now could be marked as Workaround Found because the problem was never resolved.

Words mean things!

Sorry for being so salty.

It is a bit disheartening to see the responses here. I am experiencing this problem, and having searched, have seen many others experiencing it as well. Pretty sad that this was just left in the dark.

I found this may be related to circular references in blueprints, similar to how it can occur in c++ classes.

Try to make sure your BP classes aren’t referencing each other by having a variable in the class of each other. For example, if you have ClassA with a variable CB for ClassB and ClassB has a variable CA for ClassA that could cause problems. Instead perhaps remove the variable from ClassB and dynamically reference ClassA or make the variable something generic like an actor and cast to ClassA when using the variable.