Character Running in place

Hello everyone, hope you all are safe.
My question is, everything was working normal in my game, now all of a sudden, my characters animation, running in place is playing, on begin play, even tho, i made a Blend Space, that contains idle, walk and run animation.

I tried making a new Blend Space, and tried doing other animations, but still nothing helps.
If someone had a problem like this please let me know.

Thank you

This could be a number of things.

First of all, go to your character and make sure you have the mesh set to use the correct animation blueprint.

It could also be the Blend Space. Make sure you have idle on all the spots that could possibly be 0 speed.

It could also be the animation graph not setting the speed correctly. Try putting a print string to your speed variable and make sure that the graph thinks you are at 0 when your character isn’t moving.

Finally, make sure the rules for your state machine that gets into and out of your idle/run are correct. Also, is there any other animation state that you are using in your state machines that looks like a run that might be getting triggered?

Those are the main ones I would think would be causing the issue.

1 Like

FIrst of all,

Thank you so much for the answer, i just wanted to update, i fixed the problem. In my state machine i put the Normal state for Sprint state, and Sprint for Normal. The thing is i really don’ know is how that happend, after like 40h working on the game, working perfectly normal.
But its good now, and again thank you for the help, if i didn’t found the solution you would helped me a lot with this last part of you answer.
God Bless you, and stay safe