Character relative rotation not replicated

I’ve been using a slightly modified version of paradoc’s blueprint to bypass the gimbal lock for pitching my character in a zero gravity environment. It’s working great, except the fact, that it’s not replicating. Here are his original blueprint and my version:

At first, I also was using AddLocalRotation, but after finding out about the replication issue, I tried using relative rotation, since this is shown as replicated. It produces the same result on the client, but still doesnt replicate to the server and other clients. I tried using a RPC but to no avail. Strangely enough, executing AddActorLocalRotation on the server thru a RPC replicates fine to other clients (however with gimbal lock), just rotating a component doesn’t.

I’m glad for any input, since this seems like a promising approach to removing the gimbal lock just in blueprints!

I know this is old but I figure every response helps the next guy. turns working in Euler angles instead of a Quaternion is the problem. This can be fixed by setting custom rotation maxes in the constructor for your camera manager. Setting the yaw pitch and roll to slightly less than 360deg should fix the problem. I use c++ but this is the code and values that bypass gimbal lock.

ViewPitchMax = 359.998993f;
ViewYawMin = 0.0f;
ViewYawMax = 359.998993f;
ViewRollMin = 0.0f;
ViewRollMax = 359.998993f;

hope this helps!