Download

Character Not Spawning Correctly Please Help!

Hello guy i am having a problem i made a first person project and started making a level but later realized i wanted true first person so i add the assets from the third person starter map and setup my true first person character. But the problem is that i never spawn as the character in the map i spawn wherever my editing view is and the character i spawn as is way to small and i cant edit it. I have check world settings and maps and modes to make sure it is on the right gamemode and pawn but still doesn’t work please help! I dont know what to do. It spawns as the true first person character which is good just not as the one i want that is set in the map. I did try to place a Player start as well but it does the same thing just spawns me at start doesnt actually spawn as character i want. Video of problem below.
https://youtube.com/watch?v=ZoS8E0bSC6E

There are few things that could be happening here:

Check your Game Mode and make sure the correct character is being spawned (you probably have the wrong one here)
Another thing to check, on the Editor, click on the arrow next to ‘Play’ and select “Spawn on default location” instead of current camera
Next, check if you have a Player Start

Let me know if this fixes the issue :slight_smile:

thanks for your comment the correct character is selected in the game mode and i tried to change to spawn on default location but it is grayed out i cant select it. Thanks@

Replying here because I ran into this issue, and while I believe Coqui’s is the most correct, there is another cause (completely unrelated) which will appear as a very similar problem: the in-viewport will begin to run, but the character will not spawn.

It can occur when the “Play” button has been set to “Simulate.” Fix: in the Play button’s right side dropdown, make sure the top option “Selected Viewport” is selected. :smiley: (I can attest to the frustration of trying to troubleshoot gamemodes, blueprints, and pawns, before discovering that pressing “simulate” in that one blueprint… yep that had done it.)