Character not smoothly running over collision box, causing issues

I have a prototype of an endless runner. My character slides across the ground but randomly it seems to catch the edge of the collision box of the ground piece and slows down. I tried making the ground physics material as slippery as possible. I turned on “Smooth Edge Collisions” on the ground pieces and I made sure that the pieces were all set to the same height.

Any suggestions?

Are these boxes on the edge of tiles perhaps. I think it might well be your ‘tile change’ code. Can you show some code?

1 Like

I had a similar case and i just added a vertical soft spring arm with really short distance with lagging enabled and added the camera to it… if you set it up correctly if will smooth the bumps and the good thing is that you will hardly notice that bumps !

1 Like

I got it fixed. Something to do with the the box collision that was created on the meshes. I removed the box colliders from the meshes, and created a custom box collider in the blueprint and it work.

3 Likes