Download

Character not Moving?

Hello please help. I changed the third person character by duplicating it then changing over variables and every thing, I did this for a new inventory system i was working on and got it all working. So changed over everything and got rid of original third person BP fixed some errors and everything but movement is working and just the walking not the mouse rotation or jump and inventory works can pickup items etc just not walk please help…

Ps yes i have tried gamemodes and controllers etc etc nothing worked

Screenshots please (: Otherwise we would need to use our crystal ball and that thing went missing while searching for Source Engine bugs without logs a few years ago :X

Lol Thanks for reply, here are 2 shots not sure what all you needed.

GameMode.png

Here is my game mode. I made sure everything matches up, playercontroller, thridpersoncharacterBP etc.

184316c522f19a2c52b94d34f5865545b874be9f.jpeg

This is the movement input same as the others and never no problem??

Not sure what other screenshots you might need just let me know and thanks again!

Ok guys I am in need of help can not find anything so I made a 3 min video of my problem. Hopefully everything is covered in the video, please help!

https://youtube.com/watch?v=Ux8U93sNzno

Add a print string after the add movement nodes and make sure that they are actually firing.

Thank you great idea, doing that found I out its constantly fires even without pushing a button with same result.

The constant firing is normal. If you don’t press a button, the value is just “0.0”, but they keep executing.

First of all, please double and triple check, that the CharacterBlueprint you want to use is set correctly. Make sure the GameMode is really
set and you don’t use an old one by mistake.

Then, add a PrintNode to the Axis and plug the AxisValue in the PrintString. Check if you get a 1.0 or -1.0 when pressing the keys that belong to this
Axis.

AND you had errors when shutting down the game. What are these errors? Something about AccessedNone by any chance? Post the errors please,
maybe they state something about your problem.

If the print gives out 0.0 all the time, then your Axis seemed to be blocked. Go to your project settings and make sure that the Axis are set correctly
in the Input settings and your selected the correct Keys. Also check that the multiply value behind the keys is correctly at 1.0 and -1.0.

Then make sure no other blueprint is using these Axis. If they do, make sure they are not set to consume the input. (click on the Axis Node for more options).

Ok so tried adding print node to axis value and shows it firing right, when i push W-D values show 1.0 when i push S-A values show -1.0.

So that seems to work fine and no other BP are using the axis, I also made sure in Project settings that Input values and keys were right; no problem there.

After seeing this, I imported some Mixamo characters and set game mode to run with a Mixamo character, low and behold the Mixamo characters move fine.

Now I know I can redo every BP to read off of Mixamo character then add all my variables to him to create a new character (which I will do over time) but right now just want to make regular guy move again because its days worth of reblueprinting and really don’t want to do that right away plus would like to have a base character to use to try new variables and code with.

The Accessed None Error was from my Inventory system bindings trying to read values of variables not set yet, I have been dealing with this one for awhile and has had no problem with it at any time nor did it mess with character movement.

Im starting to think that this is not for me lol as I am just lost man, kinda stinks was getting pretty far along with my BP’s.

Check character movement component and anim bp, mb you screw up something there.

Thank you all for your help, couldn’t figure it out so I just started fresh from my last backup :slight_smile: Had to do alot of stuff over but all is well, I changed the regular third person character with a Mixamo character and got it working well. Thanks again!