Character Movement Step up functionality not working when crouched

For context, I am NOT using the crouch function that comes with the character movement. Instead I am using the Set World Scale 3d function in the z direction connected to a timeline, which effectively scales my character down with no other changes. I’ve checked, and crouching does not make the collision capsule or the mesh (NoCollision on anyway) clip through the floor. I’ve also tried scaling the step height in the character movement settings way up, but that did not work. If anyone has any ideas on fixing this or has run into this problem before, please let me know.