Download

Character movement problem

hello, i have this problem with my character, it is smooth when it runs forwards but its clanky when it moves left,right and backwards, also it was doing the same thing with animations

How are you moving the character? It doesn’t seem you’re using Add Movement Input.

i disconnected the animations from the blueprint, it was doing the same thing when i had the animations

We need to see how you moving the character. It looks like the character wants to rotate but something is contradicting that rotation at the same time.

Did you start with the third person template? If so, did you change something?

what do you mean you need to see how i move the character? also yes i started with third person template and it doesn’t seem i changed anything. the following video is when i moved the camera forward to make it first person.

also, i don’t want the character to have any animation, rotation, or even exist, at this point i just want first person ( just the camera and move around)

Since you don’t have animations (which you have - to remove the animations, set the AnimClass in the mesh component to none), then it can’t be from the blendspace. So, the issue must be either in the springarm or in the character movement component.

Since your character is not rotating, you probably unchecked “Orient Rotation to Movement” in the character movement component. If you check it, does the problem persist?

In the springarm, if you enable camera lag, does the problem persist?

If you remove the springarm component, does the problem persist?

i found the problem, when i created the project imade the camera from third person to first person following this tutorial but it was a long time ago and i forgot about it

the problem is that the character is facing where the camera is also facing, every time i try to go left,right or backwards its trying to “rotate” but the setting for the character to face where the camera is facing doesn’t let it happen, so this weird thing like lag is happening, is there anyway to disable that “rotation” or other way to fix it?

and to answer to your questions, yes the problem persists after trying all these you recommended