Character Movement Issue

I am having an issue where my character is no longer receiving movement inputs when his velocity x reaches 0 when in a certain state. It’s a 2D game by the way, so just trying to move left and right and the movement mode is falling. I have tried Add Movement Input, Add Impulse, and Set Velocity each tick to current velocity +/- a value. All methods curiously stop working when the character reaches velocity x=0 unless I crank up the added values really high which i suspect means it’s skipping x=0.
I have searched through EVERYTHING in this state and there are no branches or switches etc that are conditioned on velocity, the character movement mode is not changing, and print string proves that the movement inputs are being registered. Does anyone have any idea what could be causing this to happen?

I know it’s a bummer, but it sounds like a coding problem. Might be an idea to make a new 2d project and see what differences there are in the movement code…

That is a huge bummer and I still cant figure this out.

Here’s a video showing the problem as well as pictures of the character state (Hit Stun Air) simplified to do nothing besides play the sprite and add movement and the add movement code. I added the branch after Add Movement Input to try to force the character past velocity x=0 but you can see sometimes it still gets stuck there. Sometimes it does not… :frowning: The same result happens without that branch and everything after it.

In the video I am holding left the entire time the character is in hit stun without variation.



Definitely thought I tried this, but it was the braking deceleration was > the amount of force being added. The tooltip says braking deceleration is applied when falling and not applying acceleration but it seems to be applied anyways.