Character Movement Component not working in a packaged project


I have the following problem:

My pawn is not moving (but is receiving input) when I play the game from a package and when I use “launch” option in the editor.

It does however work as intended when I use “Play in Editor”.

It’s a multiplayer game but number of clients doesn’t matter - the problem persists in all cases.
It worked before, but I have made a lot of changes since the last build I tested in a standalone version.
I haven’t made any changes to that part of the game so I don’t think I broke anything :slight_smile:
It there is no obvious solution to a problem like this, what would be a good way of trying to find it?
I’m using blueprints for everything.

thanks for help.

Hi Allshar,

  1. Did you upgrade from UE 4.11 to UE4.12 without making a copy of the original in UE4.11? If you still have the UE4.11 version, I recommend not upgrading unless you have to. If you did not save a copy, proceed with the following:
  2. What System are you developing on, Windows or Mac?
  3. What device are you packaging/launching to
  4. Run a map check on each level
  5. Check your Character Blueprint and AnimBlueprint for errors/warnings
  6. Make sure your Game Mode, Pawn class, etc. are properly set under “World Settings.”

Respond with this info and we will continue to investigate if your issue is not resolved.


Ok, I fixed it.

I had “Nativize Blueprint Assets” set to true, but my install of Visual Studio was somehow corrupted. Didn’t know, have not used it in a while.

Thanks for help.

Thanks for posting your solution. While you can use “Nativize Blueprint Assets,” if you are experiencing issues packaging, this would be the first thing I would turn off to troubleshoot.