Character mesh is none (Blueprint broken)

So, I’ve ran into some issues with my character blueprint where the character mesh has become none and unable to be changed. I’m not quite sure what caused it or if it can be remedied so I decided to check with you guys, hopefully we can fix it together!

The character I’ve made is one that has some blueprint-code which talks to the playercontroller and basically creates and possesses another pawn. The code itself works just fine, and I was able to do so multiple times before I decided to save and quit, the next time I opened up the project I noticed that there was no thumbnail for the character pawn but I disregarded it and pressed pay anyway at which point it crashed. I tried multiple times making it work and that’s when I noticed I couldn’t change the character model anymore.

This has happened multiple times now in multiple projects and I’m getting very frustrated as the code runs fine and then when I save, the file is corrupted or something. The weirdest part is that during the last two tries I created a child asset to that blueprint while it was working and when I opened up the project again the original file was corrupt as usual, but the child had the mesh working fine, except that it could not be moved within the blueprint anymore, which is pretty weird.

I’m guessing it might have something to do with me using a custom character mesh and I will check in the future if I remake the blueprint (again) if this happens when I use the regular Hero_TPP mesh, but that’s all I’ve got so far in terms of a lead. Any help is appreciated!

Note that this has happened in 4.2, 4.3 and 4.4. Version does not matter for this issue.

Hey Cindurion-

Is the mesh set inside the blueprint or in the code? Also, is it set as a UPROPERTY in the code to expose it to blueprints? Let us know if you’re able to test this problem with the Hero_TPP and also if you could post the code of how you setup the character we can take a look and see if we can find out what is happening


Hello, I just finished making a fresh blueprint using the regular Hero_TPP as a mesh. I am using the basic Character blueprint as a parent so I’m not sure about the code for it.

This time the code was working just fine before I saved and quit again, and when I loaded up the project the mesh was set to none, but it was not broken. I could change the mesh back to any mesh I wanted. I noticed upon playing that a part of the code wasn’t working though, and I checked through the blueprint and noticed that a part of the blueprint had been disconnected.

I tried connecting it again but was met with this error message so I’m guessing this part here is (at least partly) the culprit to my errors, perhaps I am using it wrongly?

I am using the get controller (target is pawn) to get the controller that is currently controlling the pawn so that I can pass it along and make sure that it is that playercontroller that gets to possess and unpossess the new character I am creating.

I have the casting node to perform a function inside of that playercontroller.

I could post all of the relevant blueprints, but I am unsure of how to do so the best way?

I created a new project (blueprint third person template) and added a new blueprint parented to Character. The mesh component of the blueprint was set to none before setting it to Hero_TPP. After compiling and saving the blueprint I then closed/reopened the project. The Hero_TPP was still set to the mesh component when I went back to the blueprint. Are there any other steps between creating a project and not seeing the correct mesh set in the components tab that I’m missing? The more detailed information you can provide will make it easier to trace the cause of the problem.

Okay, I stripped the blueprint of all code except for the transforming character part and print screened the bluprints. First I created a blueprint based off the character blueprint. I then created a second blueprint based on the blueprint I just created so that I had a character to transform into and back from.

Then I did the following in the first character blueprint:

I added an int variable that I could use to scroll between selected characters. Then I created the following function to perform the scrolling:

Afterwards I created a PlayerController (the basic blueprint one), and added these functions which basically unpossess the current character, creates a new character and possesses that one:

Then I went back into the first character again and added this function which spawns character one or two depending on the selected character in the previous function:

and lastly I made it so that the two functions were called when you press E or scroll up:

If you reproduce this you should be able to see that the mesh of the first character will be set to none the next time you open the project and go into the components of that character

Things I forgot to mention: The project I am basing it on is third person blueprint template, and I went into the MyGame blueprint and changed it so that it was using character one as the default pawn and the new playercontroller as the default playercontroller

I followed the steps as you described and was still able to see/edit my mesh after closing/reopening my project. Are you able to reproduce this in a new project? If so is there anything you do differently from what is described above?

Huh, actually… I just created a new project using 4.5 and followed my own steps and was unable to reproduce the error! I also converted my old project from 4.4 to 4.5 and the original blueprint seems to be working, so whatever it was might have been fixed in-between version 4.4 and 4.5. I’ll look into it a bit more within the next few days before I’ll call it fixed but I’m remaining cautiously optimistic.

Yep, haven’t seen the issue come up anymore, so thanks a lot for helping me find a solution!

The problem was fixed between the 4.4 version and the 4.5 version, so if you stumbled upon this issue, try updating to 4.5 and beyond and it might solve your problem!

That’s funny. I’m on 4.6 and currently having this problem. I have two blueprints extending some C++ (PickupA.h, PickupB.h) which both inherit a UStaticMeshComponent* from a parent class (Pickup.h) and one has a Pickup Mesh which is broken while the other’s Pickup Mesh is just fine. For one of the components I can’t set any of the defaults. I’ve restarted, recompiled, etc and nothing’s changed.

Hey Slowmanrunning-

The original issue that Cindurion posted referred to the asset of the mesh going missing (resetting to none). Judging by your screenshot it seems that the problem you have relates to the details of the component which would better be investigated as it’s own separate issue. It would be best if you could create a new post so that it gets the attention it needs and so it is easier for others to search if they have the same problem later.


My blueprint extending Character got the exact same problem as here: the arrow, the skeletal mesh and character movement components doesn’t have any details.If I try to recreate them, the same thing happens again. I’m using 4.7.6.

Hey Kapouett-

As I mentioned to Slowmanrunning, the issue being reported by this post is in reference to the mesh which was fixed in 4.5. The problem you’re having of not being able to edit the details panel is a separate issue that has been reported and fixed internally. This fix should be applied to the engine in an upcoming release.