Download

Character Jump node error after upgrading to 4.25

Hi! I’m trying to upgrade my project to 4.25. On my character I get the following error:

“In use pin <Unnamed> no longer exists on node Jump. Please refresh node or break links to remove pin.”

I’ve tried refreshing the node, but when I do that the input, Target, and output disappear and it says that Jump is an unknown function.

If I create a new character in the same project the Jump node is working properly.

Any ideas? Thanks!

jump.png

Does that happen even with a new Jump node?

Yes if I add a new Jump node it gets no pins:

jump2.png

wild.
verify engine files.

Even if you copy/paste from other BP?

Just for curiosity, what happens if you copy that weird jump node to another BP?

Yes. Restart the editor. And if that doesn’t work, then create a new character and move on.

Yes copying from another BP the error persists.

It works!

I’ve tried restarting both the editor and computer, but same issue. Creating a new character and copying stuff will take too long, I have lots of macros/functions and variables.

Which files do you mean and how do I verify them?

And I assume Stop Jumping is working just fine.

All I have left is:

  • What if you create a new graph, and try it there. with some luck, this only happens in the Event Graph
  • What if you make a copy of your character BP and try it there
  • Clean your project - if it’s a BP only project, delete the Saved and Intermediate files (make a backup before doing this)

Yes it works.

I tried now making a macro and function neither worked.

The problem persists.

It’s a C++ project when I upgraded I had to delete .vs, Binaries, Intermediate, Saved and generate the sln-file again to get the editor to start. So they should already be clean?

What I meant was really another graph tab:

Try it again:

  1. delete directories: .vs, binaries, build, intermediate, saved;
  2. delete files: *.sln, *.vc.db;
  3. open .uproject file and rebuild
  4. right click .uproject file and generate vs project files

Ok, I had no idea you could have more than one Event Graph, but unfortunately, it didn’t work.

Tried it but no luck.

I came up with a “solution”, I created a new C++ character class, and added a UFUNCTION which wraps “Jump();” and reparented my blueprint to this and changed the call to “Jump” to my wrapper node. It works for now :smiley:

Having the same issue, cant really work around it as such because i have a lot of my code in the characters blueprint. Any ideas?

You can still have a lot of code in the character blueprint. But this will only work if you have a C++ project. The only difference you have to do is to “Reparent Blueprint” to a C++ class which inherits from “ACharacter” which has the wrapped jump function:



// Header file
... ACharacter_Base : public ACharacter

...

UFUNCTION(Category = "Character", BlueprintCallable)
void JumpEx();


// Source file

void ACharacter_Base::JumpEx()
{
    ACharacter_Base::Jump();
}


And after reparenting to this class you can call it:

2020-07-29_13h19_00.png

I hope there is a better solution to this though :smiley:

I have the same issue in a bunch of my characters. Will mess with it later, may have to create a new BP. Will keep an eye on this thread and see if there is a fix.
The jump does work in a new character BP

To fix this in BP without having to create a new character just reparent to Character BP and then reparent back to Character :)!!! That is it, I was going to create a new character but it would have taken a long time and I had a few to do.