Character is created automatically.

Hello buddies,

I am a beginner of Unreal Engine. I created a level with the components as below,

A character is created automatically when running, Why? It’s confusing…

And the character can be controlled with keyboard.

Thanks.

Tiger Y

In the world settings, check the game mode. There’s an option “Default Pawn”, it’s a pawn the game will create automatically. Set it “none” if you don’t want a pawn to be created automatically.

1 Like

Alternatively, put the pawn you want to control into the scene, and check “Auto Posses”.

1 Like

Hi DjSt3rios,

Thank you very much! I found the option “Default Pawn Class”, but it is disabled in Unreal Editor. Could I modify it in DefaultEngine.ini manually? And what is the key name?
Thanks again! (:

Regards.

Tiger Y

Many thanks! It works for me. :smiley: