Character instantly ragdolls when starting game

wrong

Hi, thanks for taking the time to read my question! I set up my character’s physics asset today and it seems to work properly when I simulate it. I wanted to trigger it in my game however and basically my character just instantly falls to the ground when I run my project now. These are my physics settings for my Mesh and my Capsule:

Mesh:

Capsule:

It does work when I set my collision enabled to Query only, but then it doesn’t ragdoll at all anymore.

try set physical animation profile for your skeletal mesh’s physic asset to be stronger so it would need more force to enter ragdoll (How-To Create a Physical Animation Profile | Unreal Engine 4.27 Documentation) and maybe tweak value of this node, i think for most of the time, you probably shouldn’t set to 100% physical animation unreal_physicalanim_blend weight

1 Like

In your physics asset make sure the 'Physics Type" for all of your bodies is set to Default and not Simulate.

I’m sure you have this fixed by now, but this might help someone else save a few minutes.