Download

Character FBX import crash in 4.12

Hello…
Disclaimer: eidt: probably even more broken in 4.11 after a closer inspection. Stuff imports fine (mostly) but material elements are completely messed up.
Im having a really frustrating time with 4.12 fbx importing: Heres a video that decribes the issue.

https://vimeo.com/175969242/e859db3233

Here again as text: Ive got a character with roughly 72k triangles in total. Spread over body, hair, eyes, eyelashes, eyebrows, nails, teeth and tongue geos. The skinCluster is fairly heavy as it has around 390 influences in the body. One thing: Due to that it splits the body into two material elements which seems to bug with the other material elements as the next material element will affect two objects that were supposed to have an individual element each. So thats problem number one. I can fix that myself by adding a material buffer object that just contains an empty unused material.

The big problem tho is I cant seem to import the full fbx. It always crashes with different crash reports. If I remove one or two objects from the fbx it works. And it doesnt seem to matter which ones so its not a mesh specific problem.

Id really like to go with 4.12 but as it is now Its not useable for me guys. And that sucks :frowning: Again: Ive tried this in 4.11 and it worked perfectly fine so something must have broken on the way to 4.12. If you Epic Devs need my .fbx and .ma files please send me a pm and Ill get them to you discretely.

Thanks for any help,

-S

PS Ive also made an answershub question:
https://answers.unrealengine.com/questions/457682/character-fbx-import-crash-in-412.html

Which version of FBX are you using? Have you tried changing it to see if there is a difference?

Alright, I managed to get a working .fbx into the engine with almost everything working. But it took me over 8 hours of madness and I still dont know what exactly is the reason for these issues.
It would be really cool if someone from Epic could take a look at one of my fbx that doesnt work and see what they can find out.
Its a bit scary that the problem seems to be random as It can probably happen any time again.

PS: @SE_JonF, yes I tried that and a dozen other things and combinations of fbx import/export settings each of them producing some sort of crash or the material elements being all messed up.

Over the course of UE4’s various updates there have been on and off issues with fbx imports. Hopefully someone from the staff comes across your answerhub page and figures out what the issue is caused by.

Yeah me too. I can even provide them different fbx and maya versions of the asset that work and dont work for easy debugging.
AnswerHub takes a while to get picked up tho, but Im confident this can be sorted out.