Character Controller Missing "Show Mouse Cursor" Option

Perhaps a workaround is to use the Set Input Mode node instead, which I believe has a Show/Hide Mouse Cursor input boolean.

I have been trying to figure this out for a few hours now and haven’t found the solution yet, so I figured I would ask here.
So I am trying to mimic the controls from an MMO. But while trying to configure the controller based off of the default 3rd person character controller I can’t show the mouse. Infact all of the mouse settings are missing from it. And I can’t even show it in blueprints.

I have been getting really frustrated at this, and my frustration is compounded in that fact that the setting appears if I make a custom controller, but I cannot get Unreal to accept it as a controller for some reason. Any help with either fixing the problem of the default from hiding settings or helping me get a custom controller working would be appreciated.

Just tried it and it the it didn’t show the cursor and it made me unable to rotate the camera.

The only one that had a mouse option was Game and UI.

Which one did you use, Set Input Mode to UI Only, Set Input mode to Game Only, or Set Input Mode to Game and UI?

Ah I remember now - I think there is a bug that causes Show Cursor to not be in the Context menu for PlayerController.
Right-click on a blank spot in the BluePrint (don’t drag a wire), Turn off Context in the popup menu, and then get the Show Cursor node and connect the PlayerController to it.

THANK YOU. spent way longer trying to fix that alone than I would like to admit. It worked!

You’re welcome :slight_smile: Sorry I didn’t remember that sooner. It was one of the gotchas Mathew Wadstein warns us about in his YouTube “WTF” tutorial series about blueprint nodes. He also covers the 3 input modes and I think, goes over how to make them act like World of Warcraft.