Character & Camera Not Working After Possession (MP Tut)

Hi there and thank you in advance for any help.
I was following the official Unreal Engine Blueprint Multiplayer Tutorial and encountered an issue after video 23 “Finishing Up”, the second last of the series. It is where you add the GameplayPC and GameplayGM blueprints, as well as a few other things in other files.

Although Character Selection works fine after ep22 and the lobby is fully functional, clicking start and loading into the game after ep23, causes the character to spawn in as 0_base, not with the selected character, and with a messed up camera, upside down, “inair”, no controls and it gliding around like it’s on ice. The image attached shows what I mean.

I repeated this part of the series 3 times and got it all 1:1, but it still doesn’t work. I did not start with a default ThirdPerson template like the series, but a small project I had started working on, originally from the TP template. For this reason, I don’t want to just start the whole thing again, but I had no issues until now. Everything else works great. If there is a chance that my changes to files and moving the folder structure played a role in this issue, I am hoping that people will recognise it from the information and image provided and inform me thus. That way I can fix it up and continue working. Any help is appreciated, thank you!

Did you ever solved it?