Character blueprint not loading inherited functions

So I’m following the UE4 intro series on Youtube, and in episode 7 (Here’s the link to the point in the video where my issues arise - YouTube)

So for me, the “Power” section isn’t there. And I’m not sure why. I’m relatively new to the Unreal Engine, and I’ve followed the tutorial to a T, so not sure what is wrong.

Yes I know that is the next step in the video, what I’m saying is the category Power isn’t shown in my left toolbar, even though I have many places it is referenced.


UPROPERTY(VisibleAnywhere, BlueprintReadOnly, Category = Power)

the catehgory dont exist

the power is a 2000

Hey Cake,

To create a Category for your variables, click on the variable and look in the Details pane on the left. There is a drop down menu for Category that will say Default. Double click in there and type in the name for your new Category. This will place that variable in the new Category. For future variables, you will be able to select the drop down menu and that new Category will be available.

Hope that helps! Let us know if you have more questions.

Ben Halliday

Thanks for the help! Only thing I’m wondering now is that since I’ve made this category in the blueprint, how do I bring in the stuff from C++ that I’ve already written out?

In this tutorial we’ve made so far, in the power category, an object known as CollisionSphere, 3 variables, a function “CollectBatteries” which is blueprint callable, and a BlueprintImplementableEvent “PowerUp”.

None of these are callable in my blueprint like they are supposed to be. I understand the creation of a category on the blueprint side of things, but getting these to show up from C++ not so much. Any additional help would be greatly appreciated.

Did you rebuild after adding those categories from the previous videos?

Many times yes.

The only things that would make the Power Category not appear after building that I can think of is if you misspelled the word Category in your C++ or didn’t rebuild. One last question: did you click the Show Inherited Variables checkbox in the My Blueprint panel? It should be showing up directly above your Camera Category.


I dont know if I should make a new post, but the problem still persists for me.
I have ‘built’ and ‘rebuilt’ several times (Development Editor mode).
Also I checked the ‘Show inherited variables’ box.

I am also relatively new to programming and Unreal Engine.

Can we have a look at your code and the blueprint “event graph screen” in question?

I have added screenshots of both the event graph and the code of ‘TutorialCodeCharacter.h’.

All the code that I am using right now, can be found here

Thank you in advance for the help.

I still have this problem

Hi, sorry. I did not receive an e-mail about your reply.

I cannot see the top right of your event graph (I think you cropped it), but can you confirm if your “MyCharacter” blueprint is inheriting from ATutorialCodeCharacter.

Hey Jarogoondoo,

It is fixed now for me somehow.

I redid the tutorial all the way, and somehow it is now working for me.
However, I still feel that it had something to do with the communication between UE and VS, and not with an error in my code. So probably the settings in VS in my previous project were set wrong by me.

Anyway, thanks for the help :slight_smile:

Hey all,

Tieske909090: Glad it was resolved for you! If you didn’t have anything wrong in the code, than it could welll have been a setting in VS that was the culprit. However, if you run into this problem again, please let us know. There shouldn’t be anything causing a miscommunication between VS and UE4, but we certainly want to catch it if there is.

jaragoondoo: Thanks very much for looking into the issue for Tieske. Community support is the reason AnswerHub works, and we’re very grateful for your efforts. Keep it up!

CakeOrD3ath: Are you still experiencing this issue? Have you gone through the tutorial again to make sure you didn’t miss anything? I’m marking this post resolved for now, but please reopen if you still need assistance.


Still having the issue, done the tutorial twice now, everything matching to a T, tried in DebugGame Editor, Development Editor, still nothing. The only thing I can think of thats changed is in Visual Studios when it popped up with the “This is out of date” stuff, I told it not to display that anymore, and Microsoft claims that from that point on it automatically builds, but regardless of that I always build before debugging so it shouldn’t really affect anything in my mind.

Tieske909090: I’m glad you got it working in the end :slight_smile:

CakeOrD3ath: Like I mentioned earlier, are you sure your blueprint “MyCharacter” is inheriting from “TutorialCodeCharacter” (assuming you used the same names)? You can check this on the top-right of your blueprints “event-graph” screen.

Yeah it is unfortunately, so thats not it.

Looking at some of my own code which is working:

The only difference I can see is you have UClass(config=game) at the beginning which specifies the class to use the “Game” configuration file (see: I do not see why this would cause an issue, but it may be worth removing the “config=game.”

Other than that, I have specified all my members and methods to be public with a “public:” specifier.

Not sure if any of that will help, but it’s worth a shot.