Character Blueprint: Adding variable causes long compile and gradually increasing RAM

I was building my character blueprint when at some point (I was adding foot tracing IK functionality) the adding of variables(in any way, be it adding via UI or promoting a variable) began to compile for an unusually longer time (1-2 min sometimes more or less). Windows also showed me that the project wasn’t reacting for that time so it almost seemed like a freeze.
When I changed something in the event graph it compiled pretty quickly and behaved normally. Sometimes when I deleted nodes in the event graphic and created variables again it compiled quickly again as well. I tried to link it to specific nodes but it seemed pretty random to me when it happened.

Edit: This is also happening when changing settings on the character movement, the capsule but if I for example change the value of an existing variable, it’s not happening.

Edit2: I also tested migrating the CharacterBlueprint to another empty project it seems to work then…
After that I tested just copying my whole content to a new project and it seems to work as well. It’s really weird.

Build Type: Binary

Build Version: Version: 4.13.1-3142249+++UE4+Release-4.13

The attachment shows the RAM usage I experienced, it filled my whole 32GB RAM one time actually.
I’m also attaching my CharacterBP.uasset.



Hi ,

  • Do you have any other programs running when this occurs or does it occur when the editor is running with no other programs active?
  • What steps can I take to reproduce this on my end?
  • Is this limited to one type of blueprint or one type of variable?
  • How long does the memory usage increase remain before dropping again?

Sorry for the late response, I’m a bit busy.

  1. I have a lot of software running parallely usually. Steam, Skype, Mozilla Firefox, Opera, Thunderbird. I think that’s it.

  2. Reproducing I found difficuilt since it happened very randomly almost. I couldn’t really figure out the steps to it. Sorry. Sometimes when I deleted a node in the event graph it stopped happening, sometimes it didn’t. It might have to do something with non existant variables inside the event graph as well. I remember deleting a whole bunch of nodes inside the event graph and then compiled leaving some variables who didn’t belong to anything inside the variable container on the left. I later wanted to delete them and the issue began to happen, it could be another factor at least.
    Another thing I did do was create a subcategory which was behaving very weirdly I think, they seem to be a bit buggy. Maybe it’s another cause, I can’t really say for certain, sorry.

  3. It basically happened when I deleted or added a variable in my Characters Blueprint. (It didn’t seem to happen in any other blueprint). It didn’t happen when I changed things in the Event Graph etc. The type of variable seemed to not matter as well. I tried float and boolean, with both the issue happened.

  4. The memory usage is as long as the project was running, as soon as I closed the project it dropped. What happened though when I closed the software it seemed to have remained in the task manager for a good bit and then finally closed down as well. Might have been because the pc was going slower cause of the memory usage though.

As I said above what fixed it was copying my whole content folder to a fresh new project, so it might not have been an issue inside the content folder?

I could give you my whole project in which the issue happened if you need it.

If you would like to post the project I’ll be happy to take a look and see what may be occurring.

You can get it here!

Hi ,

Thank you for the project. I was able to reproduce this on my end and have entered a bug report here. You can track the report’s status as the issue is reviewed by our development staff.

This happens with a small prototype project I started in 4.15 and while opening the same project in 4.16. I think it started happening after I added a variable and changed its name. Now whenever I add a new variable OR remove a variable it causes long compile and RAM goes up