Character animations stopped working

I built my project of of the side scroller template. My character had all the default running animations and everything. I was seriously almost done and I tried to import an obj file as a skeletal mesh and got the following message. Me not know what this would do, I said yes.


Now all of my character animations don’t work and its stuck in a t-pose :frowning: Please help!! I think it did something to the skeleton of my character, I don’t know why because my obj was supposed to be an enemy.

Hey there, i think this usually happens when you override the skeletal mesh and there is something slightly different in the hierarchy, try importing the new mesh as a new skeletal mesh and set the skeleton to the same as the default and see if that works.

Thanks for the reply!

I tried a few things like that, but i didn’t know too much about if I was doing it right haha. I did however notice that my actual animation files were all tposes. Somehow they all got reset, so I created a new project and copied over those animations to replace mine and that seemed to fix it.

Thanks again, I really appreciate it!

Good to know, please upvote and/or mark the answer as correct if you think it was helpful :slight_smile: