Character animation problem

Im having difficulty working with the imported animations. How can i make the feet actually touch the ground, and not move like this? The character is not moving left and right when it should be, same with every other animation i add.


I would like the character to move like this:


First off, I’d take a look at your player character BP… make sure that your skeletal mesh is touching the bottom of the collision cylinder… it looks like your skeletal mesh component is up too high in the Z axis, so he is hovering above the ground.

Second, I’d search for foot IK (inverse kinematics) and research the many, many options there. If you’d like to keep your character’s feet planted and rotated properly to uneven ground/steps/etc, this is a fairly big topic: there is a native UE4 solution, a lot of tutorials on YouTube, and marketplace solutions too.

If neither of these solutions is what you are looking for, just comment back. I’ll see if I can help you out further…

So I made this character and rigged it in blender, I imported it to mixamo and downloaded a few animations, I unchecked root motion, yet it still doesnt work like it shows in mixamo

O M G. i made it. Instead of using my export from blender, i just exported the mesh from maximo, this fixed everything. Thanks man :slight_smile:

well, I think you’ll need root motion turned on if you’d like him to actually move back and forth…

as to his height, there are a few options I can think of

  • your pivot in Blender or the Mixamo FBX might be a bit off 0,0,0 (you could adjust this downwards in Blender/Mixamo or export your FBX from UE4, and look at it in Blender)
  • ignore the height offset for the moment, set up your character/pawn BP and reposition the skeletal mesh component of the BP lower to compensate. Combining this approach with a foot IK solution (if you need one for uneven ground) should also be OK…

I won’t claim to be an expert, just somewhat proficient… so someone else feel free to jump in

great! it sounds like it was the pivot location… I wasn’t much help, but your welcome :slight_smile: