Character an inch above the ground when play/simulate

I can’t figure out the reason why my character jumps what seems to be exactly one inch above ground when I hit play/simulate.

None of the search results helped. I have the capsule aligned correctly. When I drop the character in the default level, it aligns with the ground correctly. Tried to create completely new character, without any bp code and I get the same result.

I also added the 3rd person character and when I hit play, it actually seems to jump a bit up for a frame and then back to ground.

When I move the mesh of the character lower (about that inch) than the bottom of the capsule then when when I drop it into level it will be slightly below the ground, but when I hit play, it will jump up that inch and look correctly. But this solution feels wrong.

Any ideas?

So, even the default mannequin will move up by an inch if I bypass the control rig that’s doing leg IK. What’s going on? What am I missing? :slightly_smiling_face:

Sounds like another IK bone problem :slight_smile:

I had similar problem after animation retargeting, check if the root bone of your character is “about an inch” below characters legs :slight_smile:

P.S.
My problem is solved here, and I have figured out some more problems, and explained how to fix em, maybe this will be helpful to you too :slight_smile:

Hi, I don’t think that’s it. I’m not trying retargeting. This is happening with the simplest of setup I can imagine. New BP, Character, use a skeletal mesh, move it down so legs are aligned with bottom of the capsule. Not even animation BP used.

And with UE5 mannequin it starts to happen as soon as I disable the control rig that seems to be snapping the character to correct position.