Changing Walk Speed doesn't work?

I have searched through several threads which suggest different things such as :

-Change both Max Walk Speed and Max Custom Movement Speed - didnt work.

-Change Max Walk Speed in Construction Script - didnt work.

-Tried creating a task in my BT that change the speed under a condition - also didnt work.

-Change default values of speed at start of game to exaggerate higher and lower levels to see if there would be a difference. There was none.

What might I be doing wrong?

It depends on how you are handling input, but if you want to change the speed in general yoiu can change the scalar value attached to the key binding or input binding in the options.

If you want more control you can simply multiply the value you get from the input event and multiply it with a scalar you control at runtime.

If you want a better answer I need more info on how you handle input and how your character moves. What template did you use etc.

I simply want the characters that start moving towards each other to increase their speed. I applied a set max walk speed in my BT which simply gets the character movement and sets the max walk speed, however for some reason it doesn’t work. would you have to have a skeletal mesh? I have a cube atm to use as test, but I take it that the speed affects the blueprint in itself, it doesnt need a skeletal mesh right?

Imgur: The magic of the Internet - This is my task in my BT, It runs when two objects are heading towards each other, however the speed is the same.

You are trying to set the AI speed, so you have to adjust the speed with which the AI move to node is moving the pawn. I cant remember at the top oif my head where that is.

Somehow I set the custom movement speed to a high value again, and it worked. Thanks anyway!