Download

Changing Texture Formats for UE4 iOS Development

Hey everyone:

I’m having some issues and I believe it is due to the textures that have been imported for this project. In other mobile development projects, I have imported textures created in Photoshop and they have shown up as Format DXT1 when hovering over them. However, this project after importing the images created the same way and when you hover it shows format as B8G8R8A8. This is the only difference I can find between old successful projects and this project which crashes after the splash screen. If you wouldn’t mind viewing the reference photos and giving any insight on how to change the texture format in or out of the editor, that’d be great.

Thanks,
Brad

hi brad, I’ve just looked through one of my projects and i have both some textures with the format B8G8R8A8 and some DXT1 and they all work fine on devices i don’t have any textures larger than 1024x1024 tho.

Thanks for the quick reply! I have read in the UE4 documentation that 2046x2046 is the max, maybe this particular project just has too many textures and the memory is overloaded. Let me give that a shot! ;). I’ll let you know. Thanks again

Hey Alan:

Reducing the textures from 2046x2046 to 1024x1024 did do the trick! There are still a couple textures in the project that are 2046x2046, so I am assuming that I just had too high of a memory size. Thanks for the help. Another interesting thing though, after reducing the textures they all appeared as DXT1 instead of B8G8R8A8 formats… Ha. So I am still lost on this front. If anyone has a explanation from this or even what the difference of these texture formats are, that’d be super helpful.

Alan was your successful project with both texture formats for mobile development?

Thanks!

Ah! Tricked. It worked on Android. Still crashing after the splash screen on iOS…

So the problem was that 2048 is the power of 2 not 2046… Oversight there. Which is the difference formats Im sure… Still do not know why the iOS isn’t working, but thats a different problem. If you think it relates to the textures for why it doesnt work on iOS, please let me know what you think I should try. Thanks again

does the project launch on iOS at all? is the textures the problem?

In the texture there’s is a setting call Compression, below that in Compression Settings change Default to VectorDisplacementmap or UserInterface2D i don’t know if it the brst solution but it will change the format to B8G8R8A8 and it will work on IOS

Hi JuanJose09,

I was having the same issue and I tried what you suggested. But changing the compression settings from Default to VectorDisplacement or UI increased the resource size fairly.

Do you know any other way to solve this??