Download

Changing resulution of exported game

When i export my game the resulution is wrong and it isnt fullscreen. I know i have to change the serrings in my documents: unrealprojects/“myporject”/Saved/Config/Windows/gameusersettings.ini

I did change the resulution to what i wanted and to fullscreen but when i export nothing happens, it’s still the same resulution?

Any idea why it does this?

Firstly, you can use the following file and populate it with the GameUserSettings settings: /YourProject/Config/DefaultGameUserSettings.ini This file will then become the default for your project, and it should be included in packaged builds as well.
I’ve tried this and it works. Note that if you set ResolutionSizeX=0 ResolutionSizeY=0 and then set bUseDesktopResolutionForFullscreen=True and FullscreenMode=0 then the game will run full screen using the desktop resolution.

If you set FullScreenMode to 1 then it will use Windowed full screen. If you set Full ScreeMode to 2 then it will be windowed (in which case using desktop resolution is not really appropriate).

Finally, I had the same issue as you in that the game appeared to be 4:3 (or certainly less than 16:9) when run full screen, however I found that setting FullScreenMode to 1 (Windowed full screen) made the game use the whole screen with the correct aspect ratio.

Please dont create multiple threads asking the same issue. You already posted this question once so am closing this thread. Please continue further discussions here: https://forums.unrealengine.com/showthread.php?3143-Resulution-of-my-packaged-game!!!