Changing LOD screen size for a lot of objects

Hello guys,

so my problem is that we have a large island, built in maya and we broke it up to smaller “chunks” (~500 pieces).
Now the problem is that all of them have +1 lod. But when we import it the automatic lod distance calculated is too high(0.5 for all of them). Now since they are about the same size, we have a perfect number (0.03) which is fine, but we need to type it in manually for these (and later probably more) objects, which seems horrible especially if we want to adjust it later.

So my question is, is ther ANY way, to manually set the first lod screen size at import, for all objects? Is ther any config files for that, or even we can get into the source, if anyone can help us where to look. :slight_smile:

Thanks quys again :slight_smile:

I’d love to know this too! Can we have some feedback on this?

Any news on this?

Bump, at least make editable via property matrix. We just can’t spend hours in manualy editing LOD screen size of every mesh of a game one by one.

Ok I can’t find anything on this either. Is it just me or are the autocomputed lod distances kind of terrible. As far as I can tell, they are WAAAAY too far away to be useful. by the time lod3 loads my object is practically a point on the screen. that lod might as well be 4 pixels of color. I know we can auto adjust the lod per object, but how do we do this for the whole lod group??? I really want to know.

You can copy/paste LOD settings, screen size included, from one static mesh to another. (right-click on a static mesh in the content browser then go to Level of Detail)

Your Awesome! Oh man does that simplify things.

We need this too. There should be more ways to manage LODs globally. The LOD groups should be moved from the .ini file to project settings and should include settable culling and percentage without forcing rebuilds of geometry.

Is thier a way to copy cast shadow for lod and paste it to another mesh.
For example. Mesh has four LODs ,LOD 3 and 4 dont cast Shadows, How can i copy this setting and paste it to all the meshes